Vai al contenuto

TCP/IP

TCP/IP in pillole: DHCP lease time

Nei commenti al post precedente, Gaspar mi chiede:

Ti pregherei, se hai voglia, di spendere due parole sulla durata del lease e sull’opportunità di accorciarlo o meno.

Nelle ultime specifiche il lease time non viene raccomandato, lasciando al sistemista la scelta migliore. Nell’installazione di default di Windows Server 2003, il tempo predefinito mi pare sia 8 giorni.

TCP/IP in pillole: DHCP

DHCP (Dynamic Host Configuration Protocol) è un sistema per assegnare automaticamente un indirizzo IP agli host di una rete. E’ definito nelle RFC1533, RFC1534 e RFC1541. L’ultima implementazione è del 1997, tramite RFC2131.
Si tratta di un metodo molto comodo per assegnare e gestire un pool di indirizzi, anche per reti molto piccole. Il protocollo è molto stabile e maturo e non presenta difficoltà nella configurazione e nell’amministrazione.

Netsh: un esempio di utilizzo

Netsh E’ un comando della shell che funziona sia in modalità interattiva che batch e permette di gestire tutte le impostazioni del networking di Windows. Vediamo come utilizzare questo utile comando per automatizzare il cambio… 

TCP/IP in pillole: NAT

NATNAT (Network Address Translation) è una tecnica usata per sostituire nell’intestazione di un pacchetto IP un indirizzo, sorgente o destinazione, con un altro indirizzo. E’ definito nella RFC 3022
NAT, nel suo impiego più diffuso, viene usato per permettere ad una rete che usa una classe di indirizzi privata di accedere ad Internet usando uno o più indirizzi pubblici.
E’ stato studiato nel momento in cui ci si è accorti che lo spazio di indirizzamento IPv4 non era poi così grande come era sembrato al momento della sua creazione.
All’inizio si credeva fosse una soluzione temporanea, che l’implementazione di IPv6 sarebbe arrivata presto, invece la rapida crescita dell’accesso ad Internet ha reso il NAT una pratica molto comune, IPv6 è di là da venire, e gli indirizzi IPv4 sono sempre meno e sempre più costosi.

4 Megabit

I signori di Libero si sono finalmente accordati con quelli di Telecom, e da qualche giorno il mio router ZyXel mi annuncia tutto felice: Downstream Speed: 4832 kbps Upstream Speed: 320 kbps Peccato che la… 

Il modello a strati TCP/IP

I dati, per transitare su di una rete, devono essere divisi in piccoli pezzi, ognuno dei quali viene inviato separatamente.
Su di una rete IP, questi pezzetti sono chiamati “pacchetti”; tutti i trasferimenti di dati avvengono sotto forma di pacchetti.
Il protocollo TCP/IP è costruito con un modello a strati, in cui le informazioni si fanno strada da un’applicazione su un host ad un’applicazione su un altro host.

TCP/IP in pillole: SMTP

Il Simple Mail Transfer Protocol, SMTP è il protocollo che permette di scambiare messaggi tra host, e si occupa di gestire quasi tutto il traffico email su Internet; quindi la sua funzione è molto importante. E’ stato formalizzato nella RFC 821.
Un server SMTP ascolta sulla porta TCP/25, ed accetta connessioni sia da altri server che da client: quando inviate un messaggio, il vostro programma si incarica di contattare il server SMTP del vostro provider, che a sua volta cercherà l’SMTP del destinatario e recapiterà la vostra email.
Quello che normalmente viene identificato con l’etichetta “server della post in uscita” non è altro che il vostro server SMTP.
SMTP definisce il formato dei messaggi da trasferire e il metodo relativo: l’host mittente usa comandi SMTP per mandare messaggi all’host ricevente.

La posta

Altro quesito che mi viene spesso posto: …ho un pc ed una connessione Fastweb, no IP pubblico… e vorrei controllare il pc stesso dal lavoro / accedere ai miei files da remoto / creare una… 

La differenza fra bridge e router

Un bridge esamina l’indirizzo di destinazione hardware (MAC address) di un frame e, in base alle tabelle di indirizzi che gestisce, inoltra oppure scarta il frame. In realtà non viene inoltrato il frame originale, ma… 

TCP in pillole: ARP

Le informazioni su di una rete viaggiano sotto forma di pacchetti; per essere recapitato, ciascun pacchetto deve avere un indirizzo di destinazione fisica (MAC).
Il Media Access Control address è un codice a 48 bit che viene assegnato in maniera univoca a ciascuna scheda di rete prodotta. Dovrebbe essere unico, ma mi è già capitato di trovare due schede con lo stesso indirizzo, cosa che in teoria dovrebbe essere impossibile.
Il MAC address viene usato per identificare gli host nello strato di collegamento (layer 2) dello stack TCP/IP, ed è l’ultimo dato “logico”, subito prima dello strato del collegamento fisico/elettrico, cioè il cavo ed il connettore (layer 1).
In pratica, nella “cascata” della comunicazione TCP/IP, prima un nome host viene convertito in un indirizzo IP dal servizio DNS, successivamente l’IP viene convertito in un indirizzo MAC dal servizio ARP (Address Resolution Protocol), per identificare “fisicamente” l’host di destinazione.
ARP è definito nella RFC 826, ed è un processo concettualmente molto semplice.