Vai al contenuto

TCP/IP

SSH, porte e sicurezza

…sono dietro ad un router su sitema windows ed ho optato per l’aprire la porta 80 con un demone Apache in ascolto… Inoltre ho un demone SSH sulla 22 e ovviamente ho dovuto aprire verso… 

La posta: reti ed indirizzi IP

…ho un router con IP statico, devo collegare la rete ad internet. Ho anche un firewall … che indirizzi di rete devo usare?

Prendiamo ad esempio una rete medio piccola, con un appliance firewall (una scatola, insomma) ed un router che può essere di proprietà o concesso in comodato d’uso dal provider.
La scelta del piano di indirizzamento IP della rete locale va fatta con attenzione, specie in questo caso.
La chiave di tutto è l’indirizzo della porta WAN (pubblica) del firewall, una volta scelto quello, il resto viene di conseguenza.

TCP in pillole: DNS

DNS è l’acronimo di Domain Name Service, è un protocollo che lavora nel livello “applicazioni” del modello a strati TCP/IP.
La sua funzione principale è la conversione di nomi di host in indirizzi IP, è stato descritto nel 1983 da Paul Mockapetris nella RFC 882; l’ultima implementazione dovrebbe essere la RFC 1035.
Consiste essenzialmente in un database distribuito tra i diversi server che accoppia ad ogni nome a dominio uno o più indirizzi IP, ed è grazie a DNS che non dovete usare un numero come 66.102.9.147, ma vi basta ricordare www.google.com per raggiungere il sito relativo.

Webradio, router e DynDNS

Ricevo parecchie richieste di commentatori che, dopo aver fatto funzionare una Webradio in locale, non riescono a farsi sentire dai propri amici su internet. Oppure hanno difficoltà ad utilizzare il servizio DynDNS, che permette di essere raggiunti tramite un nome a dominio, invece che con il proprio indirizzo IP.
Riassumo qui diversi post e commenti, per ricapitolare alcune cose che potrebbero essere utili.

La Posta

Ricevo il seguente messaggio: La mia azienda ha tre sedi. Nella sede principale ci sono due connessioni internet con due router/firewall (RF1 e RF2). RF1 viene utilizzato per la connessione internet e per una VPN… 

Impostazioni ADSL Telecom

Aggiornamento: informazioni più complete qui. Mi capita spesso di installare connessioni ADSL di Telecom (o Interbusiness), sia con router in comodato d’uso che con apparecchi di proprietà del cliente. Spesso è molto difficile districarsi nella… 

TCP/IP in pillole: FTP

FTP (file transfer protocol) è lo standard per il trasferimento di files tra computer con sistemi operativi diversi. E’ definito nella RFC959, che risale a 1985, ma questo protocollo ha una lunga storia che parte nel 1971, con le prime proposte di uno standard.
Funziona al livello applicazione del modello a strati del TCP/IP, ed usa il solo TCP, mai UDP. Altra caratteristica peculiare è quella di usare due porte TCP, la TCP/20 e la TCP/21, invece di una sola. Le modalità di funzionamento sono due: attiva e passiva.

La posta

Mi è stato posto il seguente quesito: Sono un cliente FastWeb residenziale, e ho necessità di collegare diversi computer alla rete locale. Io sono un tecnico per hobby, e mi diverto a rimettere in sesto… 

www.portforward.com

Portforward è un sito che vi aiuta a configurare router e firewall per pubblicare una porta TCP/IP. L’utente può scegliere l’applicazione che intende pubblicare, la marca ed il modello della propria apparecchiatura, ed il sito… 

La posta

Ricevo costantemente, via mail e commenti, la seguente domanda Ho configurato la mia webradio/UltraVNC, in locale funziona, ma da internet non riescono a sentirmi/collegarsi al mio computer, cosa devo fare? Se il servizio funziona solo…